[distcc] distcc cross compilation toolchain for cygwin --->freebsd 6

Scott Spare scuppers at gmail.com
Mon Dec 5 14:58:14 GMT 2005

I'm having trouble with distcc that appears to come from FreeBSD and
libraries. I'm attempting to run a C / C++ compile via distcc across a local
network using Cygwin / Win2k as the host and to use FreeBSD as the target.
After many happy hours of caffeine and surfing :-) I got far enough to get
this to work somewhat.  However, I'm still getting errors about library
filename extensions in the libraries not being recognized (the .o files).

Here's the information for what all I have done:
-Cygwin install on Win box running distccd with allow options for the
correct IP for the host, target and router.
-port open on router (3632)
-build, host and target environment variables set on the cygwin (using bash
on cygwin, so using export HOST=i386-FreeBSD-Elf  etc).
-have glibc, gcc, make and the rest of the GCC toolchain.
-Cygwin installed for "all users"

on the FreeBSD Box:
-hosts are set up in the DISTCC_HOSTS env variable and in the config file
distcc uses.
-using option -j 4 or -j 8 seems to crash the local compiler, whether distcc
or others.
-distcc was set up in the CC= and C++ env variables in /etc/make.conf and
runs sometimes (as evidenced by the error being passed from distcc).
-running a make, I get errors that say it's compiling to localhost (null)
and that the file extension of the library (.o) files is incorrect. (error
1). This stops the job.
-I thought maybe that the following CFLAGS options caused trouble
-O2 -pipe -funroll-loops
so I have tried disabling these in make.conf.

Also, anyone know how I get make.conf to reparse when I start the compiler
Thanks for any help, and I will offer anyone who comes to Columbus Ohio free
caffeine for help :-)

PS I also tried crosstool... maybe it's the build type that's confusing?
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the distcc mailing list