[distcc] FreeBSD Masqerade mode issues

Chris Martin outsidefactor at iinet.com.au
Mon May 30 21:47:34 GMT 2005


I have had distcc recommended to me by a few people, and I decided to give 
it a go.

All the machines I trying to run it on are FreeBSD-5.4-p1, except for one 
dual Xeon where it is running under Cygwin.

I have the back end distccd process running fine and listening on tcp4 and 
tcp6 via inetd. Problems come when I try and actually compile.

If I run "distcc --version" I get the response I expect, but if I try and 
use the links I created as per the masquerading instructions in the distcc 
man page I can't get it working. Even if I reference the links I have 
created with absolute paths (i.e. '/usr/local/lib/distcc/bin/cc --version' 
gives the normal gcc output), so I realised that it was something else.

After some hunting around I found this: "It is possible to get a "recursion 
error" in masquerade mode, which means that distcc is somehow finding itself 
again, not the real compiler."; but I am not sure how this helps me. I have 
tried fiddling with my path order, but this didn't seem to change anything. 
I'm not sure where to go next.

here is my Masquerade directory:

baal# pwd
baal# ll
total 0
lrwxr-xr-x  1 root  wheel  21 May 30 18:50 c++ -> /usr/local/bin/distcc
lrwxr-xr-x  1 root  wheel  21 May 30 18:50 cc -> /usr/local/bin/distcc
lrwxr-xr-x  1 root  wheel  21 May 30 18:50 g++ -> /usr/local/bin/distcc
lrwxr-xr-x  1 root  wheel  21 May 30 18:50 gcc -> /usr/local/bin/distcc

Here is my path statement:

/sbin /bin /usr/local/lib/distcc/bin /usr/sbin /usr/bin /usr/games 
/usr/local/sbin /usr/local/bin /usr/X11R6/bin /root/bin

baal# uname -a
FreeBSD baal.rockdale.nsw.cw.net.au. 5.4-RELEASE-p1 FreeBSD 5.4-RELEASE-p1 
#0: Thu May 19 09:54:08 EST 2005 
root at lebowski:/usr/obj/usr/src/sys/LEBOWSKI  i386

Is there something I am missing? Or is there a different way of doing it 
under FreeBSD? 

More information about the distcc mailing list