[distcc] Re: Problems with dependency generation.

Kannan Goundan cakoose at yahoo.com
Fri Apr 22 19:41:36 GMT 2005

--- Kannan Goundan <cakoose at yahoo.com> wrote:
> (I read the FAQ and saw a similar problem mentioned, but I wasn't
> sure if you guys were aware of this particular one, so here it is.)
> I'm building dependency files at the same time as I compile:
>    gcc  -c ./main.c  -o build/obj/main.o \
>       -MMD -MF build/dep/main.d
> When I run this command locally on any one of the machines, the
> "main.d" file contains:
>    build/obj/main.o: ./main.c
> When I use distcc with DISTCC_HOSTS=localhost, the outout is the
> same.  However, when I have DISTCC_HOSTS=remote, the "main.d" file
> has:
>    main.o: ./main.c
> My current workaround is to either post-process the file with 'sed'
> or use "-MT" to add the real target (which still doesn't get rid of
> the incorrect target, but works fine).
> - Kannan

Oops, forgot to provide version info.

distcc version: 2.18.3
gcc: 3.4.1 built with crosstool, target: i686-pc-linux-gnu
hosts: cygwin (win2k), redhat 9

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the distcc mailing list