[cifs-protocol] [Solved] permission denied for cifs mount

Pierre Frenkiel pierre.frenkiel at gmail.com
Sun Dec 15 11:31:32 MST 2013

    I found the solution to my problem, and thought it may be interesting
    to post it.

    I got it by looking for all the options
    in the mount.cifs man.  The one which worked was "sec=none", i.e.

       mount -t cifs -o sec=none //wehd/hdd /d6

    I tried the other possible values for sec, and found that

       mount -t cifs -o "guest,sec=ntlm" //wehd/hdd /d6
       mount -t cifs -o "guest,sec=ntlmv2" //wehd/hdd /d6

    also work.

    At last, I discovered that the difference from my 2 other machines
    comes from the kernel versions. My curent kernel version is 3.10-3,
    but if I boot the same machine selecting kernel 3.2, the command

       mount -t cifs -o guest //wehd/hdd /d6


    That obviously means that they changed the default
    security mode for cifs in the new kernel, although I found nothing
    about that in the kernel changelog.

best regards,
Pierre Frenkiel

More information about the cifs-protocol mailing list