[cifs-protocol] Generic passthrough gpInput1 mis-named.

Hongwei Sun hongweis at microsoft.com
Mon Aug 18 21:38:51 GMT 2008


  You are correct.  It should be named as GenericPassthrough.LogonData and GenericPassthrough.PackageName in order to be consistent with the definition of the structure in [MS-NRPC].  It has been confirmed that the document will be updated in the next release.



Hongwei  Sun - Support Escalation Engineer

DSC Protocol  Team, Microsoft

hongweis at microsoft.com<mailto:hongweis at microsoft.com>

Tel:  469-7757027 x 57027


-----Original Message-----

From: cifs-protocol-bounces+hongweis=microsoft.com at cifs.org [mailto:cifs-protocol-bounces+hongweis=microsoft.com at cifs.org] On Behalf Of Andrew Bartlett

Sent: Sunday, August 10, 2008 11:20 PM

To: Interoperability Documentation Help

Cc: pfif at tridgell.net; cifs-protocol at samba.org

Subject: [cifs-protocol] Generic passthrough gpInput1 mis-named.

MS-APDS makes numerious references (eg in to

GenericPassthrough.gpInput1 and GenericPassthrough.gpInput2.  These appear to have been renamed more usefully in the IDL as LogonData and PackageName.





    UNICODE_STRING PackageName;

    unsigned long DataLength;

    [size_is(DataLength)] unsigned char * LogonData; } NETLOGON_GENERIC_INFO, *PNETLOGON_GENERIC_INFO;

Please remove references to the gpInput* names, they are just confusing.


Andrew Bartlett


Andrew Bartlett


Authentication Developer, Samba Team           http://samba.org

Samba Developer, Red Hat Inc.
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the cifs-protocol mailing list