[ccache] ccache error: Failed to create temporary file... Read-only file system

Bernd Petrovitsch bernd at tuxoid.at
Sun Oct 24 13:20:21 UTC 2021

Hi all!

On 24/10/2021 15:12, Raju C K via ccache wrote:
> The system worked fine earlier, in the same environment, where .ccache directory was read-write mounted system. No changes have been made to the configuration.

Strange - I don't think - I fail to see any somewhat valid reason that - 
it makes sense to try to get ccache to work with a read-only cache 
directory ....

Even if one disables all statistic stuff (in case that is possible - I 
never tried that) ....

> Error came up as a complete surprise, and I just wanted to verify whether any changes were made to ccache-4 that would throw up that warning.
> I will keep investigating and will report back here, if I overcome this hurdle.

Kind regards,
Bernd Petrovitsch                  Email : bernd at petrovitsch.priv.at
                      LUGA : http://www.luga.at

More information about the ccache mailing list