[ccache] [PATCH] Fix bug testing with ecryptfs

Andrew Stubbs ams at codesourcery.com
Mon Sep 10 07:57:23 MDT 2012

When I run test.sh in my home machine I get a failure in the "cleanup" 
tests.  When I run it anywhere else it passes. This confused me for a 
while until I discovered that ecryptfs is causing the disk-usage figures 
(from stat) to be somewhat larger, and is therefore changing the cleanup 

This doesn't just affect ecryptfs, of course, but any filesystem that 
has different overheads.

That's not the bug, although it's annoying.

The bug is that the test directory cannot be located outside the source 
directory, even though it's 99% set up to do so. There's just one line 
that doesn't allow it.

This patch fixes that bug and adds a comment to prevent others wasting 
their time trying to figure it out like I did.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Fix-bug-testing-with-ecryptfs.patch
Type: text/x-patch
Size: 1229 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/ccache/attachments/20120910/3575e908/attachment.bin>

More information about the ccache mailing list